Resolved
The issue has been fully resolved, and all systems are operating normally. Thank you for bearing with us.
Identified
We’ve identified the cause of the issue and are actively working on a resolution. More updates will follow as progress is made.
For support, please contact us at support@amigo.ai or reach out to your account representative.